Stopped deposits and withdrawals

Incident Report for NEAR Intents Status

Postmortem

The root cause of the previous incident was incorrectly identified.

The actual problem lied in a misconfiguration of the database connection pooling. The database connection limit was exhausted on the client side because of the increased number of locks taken to prevent parallel processing of the same deposits.

Measures are taken to prevent it from happening again.

Posted Jun 04, 2025 - 20:18 UTC

Resolved

A bug in the bridging subsystem caused a halt in all withdrawals and deposits on all networks
Posted Jun 04, 2025 - 02:00 UTC
This incident affected: Cross-chain bridging.